Quelques conseils pour la mise à jour de MT en version 3.0

Voici quelques conseils pour qui veut mettre à jour un weblog sous Movable Type vers les versions 3.0D et 3.01D. Que du vécu...

  • Si vous hébergez MT sur Apache 2, faites attention au mélange des jeux de caractères. MT3.0 utilise par défaut UTF-8 (c'est bien) alors qu'Apache 2 impose ISO-8859-1 par défaut dans certains cas (ce qui est mauvais)
  • Si vous avez téléchargé la version MT3.01D récemment, cherchez dans la distribution le dossier lib/MT/Template et vérifiez s'il contient un fichier nommé #Context.pm#. Si oui, supprimez ce fichier avant de faire la mise à jour, car votre serveur FTP peut bloquer à cause de son nom et stopper le tléchargement du reste des fichiers (ça m'est arrivé)
  • Si après la mise à jour vous ne pouvez plus vous connecter à l'interface de MT à cause d'une erreur de 'hash', détruisez le cookie mtauth lié à votre domaine et relancez votre navigateur. C'est un vieux problème de MT

J'espère que ça permettra à quelques uns de ne pas perdre autant de temps que moi sur ces problèmes, petits mais embêtants.

J'en profite pour rappeler que la majorité des utilisateurs de MT 2.x peuvent tranquillement attendre la version 3.1 qui sera certainement plus mature et leur apportera plus de fonctionnalités que la version 3.0 qui, elle, est spécifiquement destinée aux développeurs.

Laisser un commentaire

En laissant un commentaire, vous acceptez la politique des commentaires de ce blog.

Archives mensuelles

Notes récentes